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1.0 Introduction 

 
Routers may be connected to any of the ports on the TM1 / TM2. 
 
The router status or cross point information is read and UMDs may be assigned to the 
destinations or sources for mnemonic updating. 
 
Tallies may be mapped to the router destinations or sources in TallyMan via the dialog boxes.  
 
It will be seen that everything associated with the destination or source is contained within 
these dialog boxes. 
 
Router source to source and destination to source mapping may be carried out for cascaded 
routers.  This means that it two routers are cascaded with a destination on the first router 
feeding an input (source) on the second router, and a UMD is assigned to a destination on the 
second router, the correct source mnemonics of the first router will be shown on the UMD. 
 
Control is provided for the recursive depth of the linking, so tally and mnemonic information 
may be set differently. 
 
A facility is provided for the source and destination router lists to the copied to the clipboard 
and loaded into other programs such as Microsoft Excel for editing. 
 
 
Notes: 
 
For UMDs assigned to router sources be sure to set the Priority for the router destinations 
otherwise destination mnemonics will not be shown on the UMD and tallies may be slow to 
switch. 
 
As from TallyMan version V1.66, a router source display will show the final Destination 
Mnemonic that has selected that Source where there is  more than one recursion. i.e source 
to destination mapping in TallyMan. 
 
The following rules apply: 
 
Destinations with the priority set to 0 are not included.  
Priority 1 is the highest, 2 is next, etc.  
Destinations with the same priority will supercede each other; i.e. the last one scanned in a 
group of the same priority will win.  
 
 
Vision Mixers are treated as routers in TallyMan.  If a Router Destination feeds the input to 
the Mixer,  the Mixer Source should be assigned to the Router Destination. Cameras will 
normally be inputs to the Router so physical output pins may be assigned to these router 
inputs.  The camera CCUs will get a tally via the mixer-to-destination-to-router source-to-
output pins mapping. 
 
Where the Router is a monitoring router for the picture monitors and the cameras are fed to 
both to the Router Inputs (Sources) and to the Mixer Inputs (Sources ), Mixer Source to 
Router Source mapping should be carried out.  Physical output pins for the camera CCUs 
should still be assigned to the Router Sources.  See Section 3.3 for details. 
 
Loading Names into TallyMan from the router – where supported. 
 
Press "Read Names" while online in order to initiate the transfer. 
Also, please note that any background poll does not result in a mimic message unless the 
crosspoint has changed. 
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2.0 Adding Routers to the System 
 
To add a router to the system, go Offline and to the New System Icon and click on Add New 
Component.  Select a Router. 
 
 

  
 
 

  
 
2.2 Router Properties 
 
2.2.1 Name 
 
Give the Router a Name.   
 
2.2.2 Type 
 
Select the router Type from the drop-down box 
 
2.2.3 Matrix 
 
If there is a Matrix number set it here. 
 
2.2.4 Levels 
 
Set the Level of the Router that TallyMan needs to read the status.  A router will probably 
have several levels.  The level that the UMDs will be assigned to must be set here. 
 

Type in a name 
for the router 

Set the various 
parameters in the 
boxes 



 

TallyMan V1.66 on 5 Routers 

Press Apply.  The program will now jump to Set Communications.  
 
For Multi-level routers please see below. 
 
2.2.5 Assign Interface - Set Communications 
 
When the Apply button is pressed this dialog box will be shown. 
 

  
 
 
Set or leave the Assign Interface to Local for a single router level. 
 
General Parameters. 
 
Select the port on the TSL Controller / computer that is to connect to the router frame.  Give 
the Port a Description. 
 
Serial Parameters  
 
Set the Serial Parameters of the Port . 
 

 
Communications 
must be set. 
 
When set press 
OK 
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2.2.6 Multi Level 
 
If the router is Multi Level, check this box and enter the number of levels in the Max Levels 
box in the Size section.  UMDs may then be set to the appropriate level.  This assumes that 
all sources across the levels will have a common source mnemonic. 
 
If separate  / different mnemonics are required for the different router levels, enter the second 
router into TallyMan as a separate object in the tree, as show in the screen pictures.  This 
method of working offers greater flexibility. 
 
Where the router has several levels, and a common communications port, the top box in the 
Assign Interface area will not be set to Local  but will be set to the parent router for levels 
other than the first one. 
 
 
 

  
 
 
 

  
 
 
Note. 
 
In this instance UMDs will not be set in their dialog box to “Level 2” as the 2nd Level here is 
used within TallyMan as another router.  So the UMDs will be assigned to  Main Router 2nd 
Level, level 1 for both the source and / or destination mapping requirements. 
 
Where a single router entry is shown as having several levels, it is presumed that all the 
source and destination mnemonics will be the same for all levels as there will be only one set 
of mnemonic lists. 

 
Main Router 1st 
level. 

Main Router 2nd 
level. 
 
The Interface has 
been assigned to 
the “Main Router 
1st Level”. 
 
The Comms port 
used will now be 
the one set up for 
the “Main Router 
1st Level”. 
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2.2.7 Edit Levels 
 
 
This shows a router with one level. The Tally Channel Mask may be set so that only the tally 
channels required are passed through the router on that level. 
 

 
 
 
 
2.3 Size 
 
Enter the number of Sources and Destinations and confirm the Max Levels setting.  
 
Press Config Size. 
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2.4 Configure Router Names 
 
Where the router allows uploading and downloading of names, the various buttons will 
become active. 
 

  
 
 
 
 
 
 
 
 
 
 
 
A ProBel Router dialog screen. 
 

Auto update of the 
mnemonics from the 
router’s database is 
enabled here.             

The Router’s names 
may be imported into 
the Router source 
Mnemonics list. 

Where allowed, the 
mnemonic  may be 
exported into the 
Router source Names 
list. 

Auto update of the 
router’s database  from 
the mnemonics is 
enabled here.             

Mixer button labels 
may be derived from 
the selected list.             

Select Read Names on initial 
connection to ensure that 
correct router / TallyMan 
connection has been made.            
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3.0 Router Sources 
 
A click on the router source will show the following dialog box.  Double click on the Source to 
be edited. 
 

 
 
 
 
 

  
 
Src 129 shows in the Mnemonic box as this is source number 129 in this hypothetical system. 
 
Type in the required Mnemonic. 
 
The Name may be reset to the default by deleting the entered text. 
 
3.1 Mixer Label  
 
This is where the engineer decides what to offer the Mixer for Names. Names may be derived 
from: 
 
The Fixed box (VTR1)   
Or the mixer label may be derived from the Mnemonic box, near the top with the green 
characters. 
Take 2+2 will take the first 2 and last 2 characters. 
 

 
The Name box is 
only an aide 
memoir. 
 
The Mnemonic 
box shows what 
would appear on a 
UMD assigned to 
a router 
destination and 
the destination 
has selected this 
source. 
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3.2 Assignment 
 
The router source may be mapped to:  
 
·  A router source – source to source mapping 
·  A router destination – source to destination mapping 
 
With source to source mapping a Separate Mnemonic may be set which is the Mnemonic 
shown on this screen.  All tally mapping will be dynamic but the mnemonic will stay as shown 
in the box with the green text at the top of this screen. 
 
 

 
 
 
 
3.2.1 Assign to Source 
 
When this option is selected in the Assignment box,  the Display on the second router output  
will show the mnemonic and tally state of the assigned source.  In this example, “CAM 1” will 
be shown, assuming that the Router 2 Bus has selected its input, SRCE 129. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
The mnemonics for the input to Router 2, SRCE 129, are effectively taken over by the input 
mnemonics state to Router 1.  In this example, the mnemonics state shown on the UMD will 
be those for SRCE 193.  Tallies from either source will be shown. 
 
Therefore, in this example, only the mnemonics for Router 1 need be entered in the 
mnemonics lists.  
 

  
             

Router 1 
Lines 

Router 

Router 2 
Main 

Router 

CAM 1 

CAM 1 

SRCE 129 SRCE 193 

TallyMan Link 
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Source to Source mapping may also be done within one router. 
 
An exception to this is when the Separate Mnemonic box is checked.  Although the tallies 
will effectively be added together, the mnemonics will be kept separate. 
 
 
Multilevel Routers 
 
If a source is assigned to a destination, it is possible to specify a particular Level for the 
assignment.   
 
Leaving the Level set to Normal means that any UMD assignment will take its selected level 
and path through TallyMan. 
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3.2.2 Assignment to Destination  
 
 

  
 
 
 
This is used when there is more than one router in the system and displays need to show the 
correct original source mnemonic. 
 
 
 
 
 
 
 
 
 
 
 
A display on the Main Router bus needs to show the correct Lines Router source mnemonic. 
 
In the example above, Router 2 is the final Router in the chain.  Input 1 on Router 2 has the 
mnemonic “SRC 129”.   
 
This input 1 is connected to Router 1, Bus 1, which has the mnemonic “DST 161”.  Router  1 
will also have mnemonics assigned to it’s sources.  It is these source mnemonics that will be 
shown on the Router 2 Bus Display.  
 
Therefore, the linking will now ensure that the Router 2 Bus Display shows the correct Router 
1 source mnemonic which is selected by Router 1, Bus 1. 
 
Note 
 
As from TallyMan version 1.66 a Router Source display will show the final Destination 
Mnemonic that has selected that Source with more than one recursion. 
 
The following rules apply: 
 
Destinations with the priority set to 0 are not included.  
Priority 1 is highest, 2 next, etc.  
Destinations with the same priority will supercede each other; i.e. the last one scanned in a 
group of the same priority will win.  
 

  
     

Router 1 
Lines 

Router 

Router 2 
Main 

Router 

CAM 1 DST 161 
CAM 1 

SRC 129 

TallyMan Link 

The Category is 
shown as OS – 
Outside Source. 
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Direct Tallies to Source 
 
Tallies may be assigned to the router sources. 
 
Click on Add Tally 
 

 
 
 

·  Select the tally Type  
·  Select the Parent source  
·  Select the Tally  
·  and then Add to the box. 

 
Tallies may be deleted as a group and may be randomly selected using the usual Windows 
selection techniques. 
 
 
The configuring engineer may Allow User configuration access and the router source may 
be set a any one of seven Categories for easy group editing later 
 

  
 
 
3.3 Repeat Edit 
 
The Auto Inc and Auto Copy boxes may be checked for quick copying of source mnemonics 
where they are similar. 
 
The router source may be set to belong to one of seven categories for easier editing later on.

The Category is 
shown as OS – 
Outside Source. 
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4.0 Router Destinations 
 
To edit the Destination parameters, click on the router destination icon then double click on 
the Destination to be edited. 
 

 
 
 

  
 
 
Type in the required Mnemonic. 
 
 
4.1 Mixer Label 
 
The Mixer Label is shown as being taken from the Mnemonic and the first 2 and last two 
characters are used: Ou 1. 
 
4.2 Priority 
 
The Priority must be set if there are source displays.  As several destinations may select the 
same source, a system is needed whereby the UMD is “told” what to display.   
 
Priority 1 is a higher priority than Priority 2 etc. 
 

 
The Name box is 
only an aide 
memoir. 
 
The Mnemonic 
box shows what 
would appear on a 
UMD assigned to 
a source and the 
destination has 
selected this 
source or if a 
UMD is assigned 
to the Destination 
as a Fixed 
Destination 
display. 
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4.3 Repeat Edit 
  
This will allow quick automatic incrementing of mixer sources and the Auto Copy will carry on 
down the same settings for the next mixer source 
 
4.4 Direct Tallies In 
 
Tallies may be assigned to a Destination. 
 
Any UMD associated with the Destination or any Router Source UMD that is assigned to a 
Source that has been selected by the Destination will have a tally set provided that the UMD 
mask has been set to accept the tally channel. 
 
Clicking on Add Tally will show the following box. 
 

 
 
 

·  Select the Tally type  
·  Select the Parent source  
·  Select the Tally  
·  and then Add to the box. 

 
Tallies may be deleted as a group and are randomly selected using the usual Windows 
selection techniques. 
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5.0  The Virtual Tally Router 
 
There may be instances when a virtual router is required in the system.   
 
This could be used, for example, as a UMD mnemonic switch to show the transmission status 
on a UMD if a prime router destination is put to air or to route tallies automatically to the prime 
router destination if that destination has to be put to air under emergency conditions. 
 
The tally in these cases could be an external contact closure; a GPI connected to the parallel 
I/O. 
 
 

 
 
 
 

 
 
Here a Virtual Tally Router with 3 i/ps is shown. 
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The Virtual Tally Router looks at the tally status of each of its sources.  It then routes the first 
source it finds tallied, to the single destination. If tallies are set simultaneously to sources 2 
and 3, source 2 will be selected.  This is a priority system. 
 
If no sources are tallied, Source 1 is routed to the Destination.  
 
The level mask, accessed via Edit Levels, is applied to the tally status.  It determines which 
tally channels are allowed to pass through or switch the router. 
 

·  The control tally should be in a different tally channel to the tallies set to the 
destination etc. It is suggested that Iso 15 tally channel is used but any different tally 
channel to the “program” tallies may be used. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Note that the router mimic will not show the Virtual Router activity in Tools > Router Mimic.  
This mimic only shows real router activity when on-line.

Tally 2 is used to 
switch the 
Destination to 
Source 2. 
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6.0 Cut and Pasting Names and Mnemonics into the Lists. 
 
Names and Mnemonics may be cut and pasted between lists in TallyMan and Microsoft Excel 
for easy updating and editing. 
 
6.1 Using other programs to edit the Router source and destination lists. 
 
6.2 Copying Names and / or Mnemonics  
 
If the router sources or destinations are selected and copied (RH mouse button or via Edit > 
Copy Mnemonics or Edit > Copy Names) the text may be downloaded into other applications 
such as Microsoft Excel.  No delimiters should be checked for vertical filling in Excel.  Various 
delimiters are available for loading into other programs. 
 

  
 
 
Open Excel and mark the first box.  Click on Paste and the Names or Mnemonics will be 
entered. 
 
6.3 Pasting Names and Mnemonics into TallyMan. 
 
Lists may be created in other programs, such as Microsoft Excel and pasted into TallyMan. 
 
Mark the list and copy to the Clipboard.  Open TallyMan and paste into the Names or 
Mnemonics list as required. 
 
7.0 Tools > Router Mimic 
 
When the program is on-line and this box is displayed, router communication may be 
observed as cross point information is read.  This facility should be used to check for correct 
communications. 
 

The edit menu 
allows copying or 
pasting of the 
Mnemonics and  / 
or Names 
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8.0 View > Options 
 
The facility is now offered whereby the drop down lists may show either the Name or the 
Mnemonic associated with the router, for example.  The Index number may also be shown, if 
required. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
This shows the Index number and the Name
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This shows the Index number and the Mnemonic. 
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9.0 Tools > Edit Source Panels 
 
Use with the User Screen 
 
This allows individual source selection,  hence router changes, once a monitor has been set 
to a Destination. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

·  Enter a Monitor and assign as Destination to it.  Drag and drop the Destination into 
the monitor. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
This option determines how the text in the monitor will be displayed.  Seen via the Setup > 
View > Options dialogue box. 
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If required: 
 

·  RH mouse click on the monitor 
·  Load the appropriate Source Panel settings from the saved .tss file. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
To Edit Source Panels 
 
Panel buttons may be allocated to the sources as described below. 
 
When this option is selected both the Source Manager and Source Select Panel Editor will 
open. 
 
It is possible to drag and drop the sources onto the buttons.  A LH mouse click will remove the 
assignment. 
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Select the Router and then Initialise and the buttons are auto-filled.  This shows that Normal 
has been selected. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 

Routers 24 TallyMan V1.66 on 

If Initialize > Category Sort is selected each category is put on separate pages. 
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A Custom File may be saved / loaded by clicking the Default button  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Or by selecting either the Save or Load buttons, as appropriate. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

·  Write this setup to the TMx 
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Then, when on-line go to the User screen: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Press on the button graphic if you have a touch screen or click with a mouse, 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
This screen will reappear and sources may be selected to the monitor. 
If Close on Select is checked, the screen will disappear on touching a source button. 
 
Notes:   
 
When on-line alternative panel selections and destination control settings may be loaded. 
The program will show which source has been selected even if a hardware panel is used to 
make changes. 


